National Gun Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Purchased a new Savage 223 from Big 5 and and tried 60 rounds, 20 from three different boxes. 20 American Eage and 40 Frontier. 20 of the Frontier failed to fire. 1 of the American Eagle. Have not had any trouble with Frontier in my Henry 223 single shot. Looked online discovered other people have had same problem with the same rifle and other brands of ammo. Big 5 initially said I could return it, then they changed their mind. Savage wanted ME to pay to send it to them which I pointed out was ridiculous on a brand new gun, that I literally had just bought. They sent a prepaid label but gave no recommendation as to how to ship it. So, I used the original box but wrapped it twice in package shipping paper and mailed it back. We'll see what happens. I had heard good things about Savage before but I guess quality control has gone downhill.
 

·
Aim true !
Joined
·
10,259 Posts
Mine works fine. I use cci primers for my loads. Hope Savage makes it right for you.
 

·
Live Free
Joined
·
2,867 Posts
Sounds like it may have preservatives from the factory gumming up the bolt...did you try cleaning it? Too late for that now if you already sent it back to Savage.

I have had great service from Savage on a couple of occasions, I suspect they will get it right for you too.
 

·
Registered
Joined
·
13,196 Posts
^^^^ what he said. First thing you should always do when buying a anew gun is thoroughly clean and lube it.
 
  • Like
Reactions: AgedWarrior
1 - 4 of 4 Posts
Top