National Gun Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Before shooting my P320 Legion the first time I cleaned the internals.

During my 200 rounds of shooting on a few occasions the empty shell would get jammed in the retractor, and on some last empty magazine rounds the slide did not open.

Any help would be appreciated, thank you in advance.
 

·
Registered
Joined
·
1,035 Posts
Clean and lube the gun (again).
Change ammo to make sure it's not just a bad batch.
Make sure you're not limp wristing the gun and inducing feed or extraction issues.
Mark your mags and see if the slide issue is happening to all mags or just one.
Run a few hundred more rounds through it for break-in, if problems persist contact Sig.
 

·
Grand Imperial Poobah
Joined
·
22,251 Posts
Run 500-600 rounds through it and the problem should go away.
 
  • Like
Reactions: fixitfred

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Thank you all for the help, and suggestions.

Just came back from range with shooting 200 rounds within no issues.

I changed the spring out, and lubed again with using the same ammo plus another brand, and the same 5 magazines I have.

I think the back sight guide needs to be adjusted some tho.

Peace out, Happy New Year!

Quote Edit
 

·
Banned
Joined
·
142 Posts
Clean and lube the gun (again).
Change ammo to make sure it's not just a bad batch.
Make sure you're not limp wristing the gun and inducing feed or extraction issues.
Mark your mags and see if the slide issue is happening to all mags or just one.
Run a few hundred more rounds through it for break-in, if problems persist contact Sig.
+1
 
1 - 5 of 5 Posts
Top