National Gun Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
So put together an ar a few months back with a PSA lower and bcg and a radical arms upper. I’ll take it out shooting after cleaning and it runs like a champ, put it in the case and a few days later go back out and it doesn’t cycle properly, always missing every other round and occasionally jamming, also like to add I use pmags and the lower and upper have slight play between them..
 

·
Registered
Joined
·
3,150 Posts
You need to analyze what changed. What does run like a champ mean? How many rounds? What kind of lube did you use? Same ammo?
 

·
Registered
Joined
·
13,204 Posts
When you say it's missing every other round do you mean it fires, ejects but does not pick up the next case to feed and closes on a empty chamber? If so that could be one of several problems. Too heavy of a buffer, weak ammo or maybe not enough gas pressure. First thing would be to try different ammo and then maybe lighten the buffer if that don't work. Where does t throw the empty brass? Does it throw them forward, backward or at 3 oclock to the right? usually around 3-4 oclock position tells you the gas system/buffer is working properly. if it's further back than that a lighter buffer may be needed. If it's forward it usually means over gassing but that usually wont cause short stroking. Also do you have it oiled properly? Ar's like to be run wet so if it's really dry it could be causing so much resistance that the bolt isn't moving like it should. There are other things too but being it's new i doubt it has a clogged gas tube or worn gas rings etc.
As far as the rattle between the receivers that's fairly normal on a AR as long as it isn't excessive. You can buy a thing called a accu wedge which is just a little rubber wedge that drops in the back of the lower. You trim them to fit ans you should feel a tiny bit of resistance when they are set up right when closing and it removes at the rattle. I use them in mine.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
To answer everyone’s questions by run like a champ I mean that after cleaning(with clp) it blew through about 13 pmags of both American Eagle 5.56 and hornady black 223 without any issues. I’m usually very good about cleaning my weapons but it was 3 days later and hadn’t had the time yet, took it out and it went through the first mag and then after that it started missing rounds and a jam every now and again, by missing rounds I mean firing, ejecting but not picking up the next round. As for where it’s throwing the brass I haven’t really payed attention to that but I will for sure next time.
 

·
Grand Imperial Poobah
Joined
·
22,270 Posts
Give it a good cleaning and lube, then try it again. If your AR is new, it may not be fully broken in yet. It sometimes take 500-600 rounds for a firearm to settle in.
 

·
Live Free
Joined
·
2,873 Posts
I second Mad Scientist post. Takes some rounds to break them in and ya got to keep it well lubed. Cleaning and maintaining mags is important too.
 

·
Registered
Joined
·
2,988 Posts
Make sure the gas key is tight on the bolt. I had a similar problem with an AR and chased that problem relentlessly. I bought new springs, buffers, ect I even took it to a gunsmith. I eventually took the gas system apart and cleaned it to see if that would help and it was when I started putting it back together that I grabbed the bolt by the gas key and lo and behold it was loose and yes the bolt heads were straked. I tightened them up and not one hiccup to this day.
 
1 - 9 of 9 Posts
Top