7.62/556 AR pistol issues
Advertise with us Click for Rates
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Mar 2020
    Posts
    1

    Default 7.62/556 AR pistol issues

    I have a 7.62 and 556 pistol 10 inch barrels that are currently sharing a lower anderson reciever. when I first shot both barrels would fire the round, but would not eject the casing and would try to load another round. I changed out a 4.7 ounce buffer for a 3.0 oz..it also did not inject the round properly but did not try to jam the round as hard. the 556 tried to load the new round in and the 762 barely moved the next round out of the magazine....any tips or thoughts in what's wrong??

  2. #2
    Genius in Training RZR6-4's Avatar
    Join Date
    Feb 2016
    Posts
    473

    Default

    Could have too stiff of a spring in the buffer tube. Gas systems could be set wrong on the uppers thus not giving enough energy to the bolt carrier. If they were assembled by the same person then that person probly didn't know what they were doing and don't have the holes lined up correctly or something like that. If they are from factory then most likely an issue in the lower somewhere.
    Henry Lever Action 22 / Harrington and Richardson GameMaster
    Remington 870 / Savage 11 Scout
    Remigton 522 Viper / Mosin Nagant M91/30
    Mosin Nagant M44 / Core 15 Keymod Scout
    Parts kit AR15 / Sig P320

  3. #3
    Senior Member saiga 308's Avatar
    Join Date
    Sep 2019
    Location
    utah
    Posts
    216

    Default

    Quote Originally Posted by dackle View Post
    I have a 7.62 and 556 pistol 10 inch barrels that are currently sharing a lower anderson reciever. when I first shot both barrels would fire the round, but would not eject the casing and would try to load another round. I changed out a 4.7 ounce buffer for a 3.0 oz..it also did not inject the round properly but did not try to jam the round as hard. the 556 tried to load the new round in and the 762 barely moved the next round out of the magazine....any tips or thoughts in what's wrong??
    the 7.62 issue seems different more of a gas port issue does it have a adjustable gas plug? or is the tube the correct length?

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)