Advertise with us Click for Rates
Reply to Thread
Results 1 to 1 of 1
  1. #1
    Junior Member THE Gunslinger is on a distinguished road
    Join Date
    Feb 2012
    Location
    North Carolina
    Posts
    8

    Question Browning A5 12 Gauge Ejection Problems HELP PLEASE :smile5:

    My Browning does not eject shells after the first shot, making the semi-auto not work and the shells must be manually ejected after every shot. ive heard that your supposed to change the friction ring to make it fire Lighter loads to make it eject properly, but ive tried the lighter load setting and the higher load setting with field shot (on light setting) and buckshot(on heavy setting).There are instructions on the back of the magazine tube cover to do this, so I know ive tried both options correctly, but I am still having the ejection problem. Please help if you know any information on how to fix this.

    P.S. : Im estimating that the gun is 50+ years old, but had worked perfectly until I disassembled it for a school project, after I reassembled it I noticed the problem.
    Attached Images
    Last edited by THE Gunslinger; 02-06-2012 at 08:05 PM.
    .x:X GUNSLINGER X:x.
    Girls LOVE me

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Search tags for this page

browning a-5 problems
,
browning a5 ejection problems
,
browning a5 not ejecting shells
,

browning a5 problems

,
browning a5 troubleshooting
,
browning new a5 problems
,

new browning a5 problems

Tags for this Thread